TrainACE - IT and Cybersecurity Training Blog

New Version of the ECSA / LPT (v5) Certification by EC-Council, Coming in 2014

[fa icon="calendar'] Oct 24, 2013 2:02:52 PM / by Ryan Corey posted in advanced ethical hacking, advanced penetration testing, advanced security, certified ethical hacker, Cisco, cybersecurity, EC-Council, ECSA certification, LPT certification, security training

[fa icon="comment"] 0 Comments

EC-Council has just announced that a much overdue improvement and version upgrade to the ECSA / LPT curriculum will be coming to training centers (ours, of course, is the only one that matters) at the beginning of 2014.

Read More [fa icon="long-arrow-right"]

Need IT Certifications?
Want more info?

Call (301) 220-2802


or

New call-to-action

Lists by Topic

see all